“There is a missing project subtype…” error on adding a Windows 10 UAP project in MonoGame 3.4

I decided it was a good idea for me to enter the Hull Windows 10 Game Jam (or Windows 10 Three Thing Game, or Yorkshire Game Jam) this year, drawing on my nearly non-existent knowledge of game development and the tiny amount of work I did with XNA a couple of years ago.

Hey, I never said it was actually a good idea.

As MonoGame added Windows 10 support a little while back, I thought I’d try and get some practice in with it before the event. So, after setting up a Windows 10 dev box and downloading MonoGame, I created a new solution and added a MonoGame Windows 10 UAP project to it.

When I added the project, I ran into an error saying “There is a missing project subtype. Subtype ‘{[GUID]}’ is unsupported by this installation”. This was because I didn’t have the Windows 10 development tools installed – all I had to do to fix it was install the tools from here.

Problem connecting to TFS 2015 RC in browser from machine on same domain

I’ve been playing a little bit with TFS 2015 recently. The setup I’ve got going at the moment is a Hyper-V server with 3 virtual machines in a domain: a DC, a TFS server, and a build machine.

Build agents are deployed differently in TFS 2015 than they were in TFS 2013. Instead of having to run the TFS installer on each build machine, you can now download a build agent from your TFS server through your browser. So, to set up my build machine, I opened up a browser, typed in the TFS server’s URL… and was immediately greeted with the generic “Internet Explorer could not display this page” error message.

The culprit in this case was firewall rules. It turns out that when TFS is installed, it adds a rule to allow connections through port 8080, but it only adds this for the public profile. Changing this rule to allow connections from the same domain fixes the problem:

TFS Firewall Rule After